Pat_1087(乙级) | StriveZs的博客

Pat_1087(乙级)

1087 有多少不同的值 (20 分) 原文地址

当自然数 n 依次取 1、2、3、……、N 时,算式 ⌊n/2⌋+⌊n/3⌋+⌊n/5⌋ 有多少个不同的值?(注:⌊x⌋ 为取整函数,表示不超过 x 的最大自然数,即 x 的整数部分。)

输入格式:

输入给出一个正整数 N(2≤N≤10​4​​)。

输出格式:

在一行中输出题面中算式取到的不同值的个数。

输入样例:

2017

输出样例:

1480

代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
#include<iostream>
#include<vector>
#include<algorithm>
#include<math.h>

using namespace std;

int main(){
vector<int> dir;
int n;
int num = 0;
cin>>n;
for(int i=1;i<=n;i++){
int sum = floor(float(i/2)) + floor(float(i/3)) + floor(float(i/5));
if(count(dir.begin(),dir.end(),sum) == 0){
dir.push_back(sum);
num++;
}
}
cout<<num<<endl;
return 0;
}
StriveZs wechat
Hobby lead  creation, technology change world.
  • Post author: StriveZs
  • Post link: 1798.html
  • Copyright Notice: All articles in this blog are licensed under CC BY-NC-SA 3.0 unless stating additionally.